
Introduction to Adobe Photoshop for Scientific Imaging

John C. Russ
Materials Science and Engineering Department., North Carolina State University, Raleigh, NC

Photoshop is many things to many people
A digital photography post-processing and printing tool
A graphic arts creative tool
... and much more ...

Each of these applications use only a portion of the software’s capabilities. Our interest is in those routines that 
are appropriate for digital imaging as used in scientific and technical applications. 

There are literally hundreds of books and other resources that claim to “teach Photoshop.” Many of these are 
directed at a specific market segment, and many are, frankly, useless or worse for scientific and technical 
purposes. A few of those that do present useful and correct information are listed below; all are available 
through Amazon. Answers to many questions can be found in the Photoshop Help menu or in the printed 
manual (if you have one), and many of the books out there do nothing more than repeat this information. Many 
of the books available have versions that are specific for each version of Photoshop, because some things have 
been added, some selections and menus have moved around, and some options have changed. All of these books 
contain much information that is aimed at other areas of program use.

McClelland, D. “Adobe Photoshop One-On-One,” O’Reilly Media (one of the better repackagings of the 
manual, if you need one - another good choice is Adobe Photoshop Classroom in a Book, Adobe Press)

Margulis, D. “Professional Photoshop - the Classic Guide to Color Correction,” Wiley (the definitive text on 
color management, primarily for photographers)

Blatner, D., & Fraser, B. “Real World Adobe Photoshop” Peachpit Press (encyclopedic description of all the 
functions and information on individual customization; shortcuts, tips and tricks; important details about 
printing on offset presses)

Some general background about Photoshop
1. The current version of Photoshop, CS4, is also Photoshop 11.0. Versions from 7.0 on provide most of the 

capabilities discussed here, and any of these can be used. All support the same plug-in architecture, will open 
(most) of the same file types, etc. The additional capabilities of the more recent versions such as full support 
for 16 bit images, more complete automation capabilities, additional processing routines, etc., are useful but 
not essential for most purposes, so if you have a slightly older version, don’t be in a rush to upgrade. The 
most recent, CS3 and CS4, run only under Windows XP with service pack 2 or Vista, or Mac OSX 10.4 or 
later.

2. Photoshop will open (or save) a wide variety of image formats, and there are plug-ins that can handle 
additional ones such as Dicom (used for medical imagery), FITS (astronomy) and even spreadsheet arrays of 
numbers. But it is very important to avoid as much as possible the use of formats such as JPEG that discard 
information from images. “Lossy” compression produces small image files, convenient for emailing perhaps, 
but inappropriate for any serious processing or measurement. TIFF (*.tif) files are a good choice because they 
can be saved or read by most programs on most computer platforms.

3. Photoshop has versions for Windows and Macintosh which are virtually identical in appearance and user 
interface. Images saved with either can be read with the other (it may be necessary to add the file type 
designation, e.g. *.tif, to a file to allow it to be recognized under Windows). Plug-ins written for one platform 
will not run on the other, however, but must be recompiled from the original source code, something that 
only the creator and owner can do. In the descriptions below, the Windows key names are used. The 
Macintosh equivalents are Control = Command and Option = Alt. If you are using a one-button mouse, an 
option-click is equivalent to a right-click. 
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An outline guide to the most important things you should know

Note:  *.tif images used in these examples: Astro_R, G, B; Bird; Butterfly; Cat; Pollen-C, G; Writing.

I. The desktop
A. There are many “Palette” windows, with tools, information, and controls.
B. Only a few are typically used and open at any time.

1. For most purposes the important ones are:
a. Tools (which allows selecting tools and display modes).
b. Info (which shows individual pixel values, region dimensions, etc.).
c. Histogram (which shows the distribution of pixel values for the image).

If a warning sign appears in the histogram palette it means the display shows the results for a 
sampling of the image (prevent this by setting the cache level to 1 in the preferences). Click 
in the histogram display to force the program to get the true values.

d. History (which shows and allows selection of previous states for your image).
e. Channels (which manages the color and selection channels present).
f. Layers (which manages the layers present, some of which may hold text or line annotations).

Actions (if you have created automated sequences for common tasks).
C. Select those you want from the Window menu, drag to arrange them.

1. A window can be shared between several palettes (drag the tab into the window dock).
D. Save your workspace (Window -> Workspace -> Save) to preserve your setup.
E. Press the “Tab” key to hide or restore the palettes (useful on a small screen).
F. Press the “F” key to show the current active image by itself (press “F” again to recover).
G. One or many images may be open at once.

1. The active image is on top and has a highlighted title bar.

II. Viewing an image
A. Zoom with keystrokes (Control-+ and Control-– or the magnifying glass tool and the Alt key).

1. When an image is zoomed to less than 100%, the display does not show all of the pixels; 
edges and lines may appear to be broken but this is purely a visual screen effect.

B. Fit the image to the screen with View -> Fit on Screen (shortcut Control-zero).
C. Scroll the image or drag with the mouse using the hand tool.

1. Depress the Space bar to temporarily turn any tool into the hand for scrolling.
D. The cursor changes with the tool selected (if this option is selected in Preferences)
E. Multiple views of an image (e.g., with different zoom settings) may be useful for seeing details (Window -> 

Arrange -> New Window for ...name...). Processing can be performed with any of the views.
F. Learn to use Undo (Control-Z) and History (Figure 1); the processing steps can be saved in the image file.

Figure 1. The history palette allows selecting an earlier step in the processing.
Each open image has a separate history.

G. Always keep the original version of your image, and use File -> Save As to save your results.
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III. Menus and submenus
A. The “Image -> Adjustments -> Levels” format is used here to specify a main menu, menu item, 

and submenu item, respectively (Figure 2).

Figure 2. Photoshop s hierarchical menu layout

B. There are many (!) keystroke and function key shortcuts (for the power user).
C. There are also menus in each palette window (click on the small icon at the top right). The most useful are:

1. Info -> Palette Options (Figure 3)
a. It is particularly important to set up the Info window to show the most useful information on color 

values and dimensions. Usually this will be the RGB values (which also apply to gray scale 
images) and pixels.

   
Figure 3. The Info window and its options dialog. Pixel values are shown in RGB, and cursor position,

region dimensions and ruler measurements are shown in pixels.

2. Histogram -> Compact View, Expanded View (Figure 4), All Channels View

Figure 4. The histogram palette (expanded view) shows the distribution of pixel brightness values. 
For a color image this is the average of red, green and blue. Other options can be selected.
such as individual color channels or the weighted luminosity. If a region has been selected,

the histogram shows only those pixels.

3. Channels -> Merge Channels, Split Channels
a. Merge Channels combines three gray scale images of the same size as the red, green and blue 

channels of an RGB color image (Figure 5).
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b. Split Channels separates the red, green and blue channels of an RGB color image and shows them as 
three separate gray scale images.

Figure 5. Merging channels combines individual gray scale images (Astro_R, G, B.tif) into a single color image

4. Actions -> New Action, Save Actions, Load Actions, Start/Stop Recording
a. If you have created actions to record sequences of commonly used operations, they can be assigned 

to function keys or used for batch processing. Sets of actions can be saved to disk.

IV. Tools
A. Select a tool with the mouse (click and hold to view options) or with key shortcuts.

1. Pressing a letter key (without Control or Alt depressed) can be used to select the tools. Hold the Shift 
key down to select among the multiple versions of each tool. For instance M selects the marquee 
selection tool. Shift-M alternates between the rectangular and ellipsoidal modes.

2. The tool selections you will use most are:
H=hand tool (scroll an image that is larger than the window)
Z=zoom (magnifying glass)
B=brush (which includes the pencil tool)
M=marquee (outline a rectangular or ellipsoidal region, or a single line of pixels)
L=lasso (for drawing freehand selections or outlining a polygonal region)
W=wand (select a region based on brightness)
L=line tool (as well as other shapes for drawing)
T=type tool
I=eyedropper tool (also the ruler)

3. Placing the cursor over a tool in the palette will display the keyboard shortcut letters (Figure 6). Brief 
descriptions of icons in the option bar and other palette windows are also shown this way. 
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Figure 6. The Tools palette window, showing multiple tool versions and shortcut keys

4. Tools have multiple options and presets. The most commonly used are:
a. Marquee selection (Figure 7) can be “Normal” (i.e., freely adjustable) or may have fixed sizes which 

can be saved as presets (click on the arrow at the left side of the bar to set or recall a preset).

Figure 7. Two views of the Marquee option bar, showing normal (adjustable) size and fixed size settings.

5. Selections may be anti-aliased (usually the best choice is to not anti-alias, so that pixels are either 
fully included for processing or not included).

6. The wand tool (Figure 8) has a tolerance setting for the brightness or color difference (from the original 
location clicked) of pixels to be included, and can select contiguous regions or pixels in the entire 
image.

Figure 8. The wand tool option bar set to select contiguous pixels.

7. The eyedropper can be set to read individual pixels or average a small area.
8. The line tool (and other drawing shapes) can draw as either bit maps (modifying the pixel values in the 

image) or vectors (in a separate layer, usually the better choice). The bit maps may be anti-aliased 
for a smoother appearance. The line width can be adjusted.

9. The option bar for the text tool has a check mark (for OK) and a cancel symbol which are used to end 
text entry. Several other tool option bars (such as Edit -> Transform) also use this convention.

B. The Tools palette also shows the foreground and background colors (click on them to select a color).
Setting exact black and white can be done by clicking on the icon in the tools palette, or pressing D.
Interchanging foreground and background can be done by clicking on the icon, or pressing X

C. At the bottom of the tools palette are icons that can be used to select the Quickmask display mode for 
regions, or to set full screen display mode.
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V. Adding lines and labels
A. Photoshop creates a separate layer for text.

1. Text can be rotated using Edit -> Transform -> Rotate (for arbitrary angles) or Edit -> Transform -> 
Rotate 90° (for vertical orientation).

2. Text layers cannot be processed, but can be edited or the position shifted (select the layer and use the 
Move tool, or depress the Control key while dragging with the mouse or using the arrow keys).

B. The Text tool has options for font, color, style, justifying, etc. (Figure 9).

 
Figure 9. Text options and the Character palette (shown by clicking the icon marked in red).

C. Lines, etc., may be drawn either in a separate layer (usually the better choice) or directly in the image.
1. Adding arrow heads may be useful for labeling (Figure 10).
2. Anti-aliased lines have a smoother appearance for labeling purposes.

Figure 10. The line tool options bar set to draw directly into the image pixels (icon marked in green), with 
anti-aliasing and an arrowhead. Clicking on the icon outlined in red draws lines or shapes in a new layer

D. Both the paintbrush and pencil tools draw directly onto the image but there here is an important difference. 
1. All pixels are set to the foreground color by the pencil (Figure 11), but the paintbrush has “soft” or 

blended edges that make a pretty anti-aliased effect, but the variation makes selection difficult.

Figure 11. The Pencil tool options bar. The [ and ] keys can be used to adjust the size.

E. Drawing is done using the foreground color (and erasing with the background color).
1. Setting the “hardness” of the eraser tool to 100% produces complete erasure (or use the pencil tool with 

the foreground color set to white).
2. To add text and line labels in color, you must first convert a gray scale image to RGB color (Image -> 

Mode -> RGB Color).

VI. A few other useful tools:
A. The eyedropper reads the color at any point to set the foreground color. Depress Alt when clicking the 

mouse to set the background color instead.
1. With the pencil and line tools, depressing Alt temporarily changes the cursor to the eyedropper to select 

a foreground color for drawing.
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B. The ruler tool can be used to manually measure distances and angles (click and drag).
C. The counting tool (new in CS3) can be used to count clicks and record their locations on the image.

1. In CS3 it is possible to save the measurement values and counts to a file.

VII. Selections
A. Selections allow accessing only that region for processing, copying, displaying the histogram, etc.
B. Pixels may be “partially” selected (feathering). This usually makes a prettier result but is not appropriate for 

most scientific applications.
C. The marquee, lasso, and wand tools select portions of an image. So does Select -> Color Range.
D. Selections are shown by “marching ants” or a Quick Mask display that hides unselected pixels.

1. The Quick Mask is an 8 bit image that can be processed, drawn on, etc., to create or modify the 
selection. The marching ants indicate pixels that are at least 50% selected; they can be hidden.

2. Feathering a selection is equivalent to applying a Gaussian blur to the Quick Mask,
3. The color used in the Quick Mask hides unselected pixels. If it is more convenient to use the mask to 

mark selected pixels, double-clicking on the Quickmask icon in the tools palette allows reversing this 
mode, and also choosing a color for the mask overlay (Figure 12).

Figure 12. The Quick Mask Options palette.
E. Inverting a selection (Select -> Inverse, or Shift-Control-I) deselects the current pixels and selects all of the 

others. It must not be confused with inverting the pixel brightness values within the selection 
(interchanging black and white, which is Image -> Adjustments -> Invert or Control-I).

F. Selection and drawing tools are modified by constraint keys.
1. The Shift key makes rectangles square, ovals circular, constrains lines to 45 degree steps.
2. The Alt key draws rectangles and ovals from the center instead of the upper left corner.

G. Depress the shift key to add additional selection regions, the Alt key to remove a region from an existing 
selection.

VIII. Layers
A. The concept of layers is a “stack” of pages, shown in the layers palette.

1. One use for this is to keep copies of each stage in processing an image (Figure 13).

Figure 13. The Layers palette, showing several steps in processing and labeling an image.
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B. Layers can be created by pasting or duplicating (Layer -> Duplicate Layer).
1. Naming layers is useful for keeping track (double click on the name and enter a description).

C. The Layers palette is used for selecting a layer, and for turning layers on or off for viewing.
1. Click on the layer name to select it for processing
2. Click on the eye icon to turn the layer visibility on or off.
3. Layer visibility must be turned on for drawing or processing, but need not be the topmost layer and 

hence may be hidden from view.
D. Layers can be individually moved for alignment. 

1. Depress the Control key and drag with the mouse, or use the arrows for fine tuning.
E. Selections within a layer can be erased (made transparent) be selecting Edit -> Clear or pressing Backspace.
F. Layers have viewing modes and opacity.

1. The “Normal” (and occasionally “Difference”) modes are most appropriate for scientific applications.
2. Adjusting the opacity of the top layer can be very useful for comparing one image or processed result 

to another.
G. Layers are combined by “flattening” an image. Edit -> Copy Merged (Shift-Control-C) places a flattened 

copy of the image on the clipboard without affecting the layers structure.
H. Some file formats do not support multiple layers and saving a copy will be automatically flattened.

IX. Channels
A. The Channels palette (Figure 14) is used for viewing or accessing color channels.
B. There may also be selection channels for portions of an image, which are saved with it.

1. Select -> Save Selection creates a selection channel, Select -> Load Selection brings it back.

Figure 14. The Channels palette and its menu. Two selection channels and three color channels are shown.

C. Images come in various modes - 8 or 16 bits, Gray/RGB/Lab/CMYK, or Indexed Color.
1. Images are usually acquired from cameras or scanners as Gray or RGB, with 8 or 16 bits per channel. 
2. Some instruments save images in indexed color mode, which must be converted to Gray or RGB for 

processing.
3. Always maintain an image in as high a bit depth as used for acquisition.
4. CMYK is primarily used to fine-tune the appearance of offset printed images.
5. Lab color is useful for many image processing steps because it separates brightness (L=Luminance) 

from color (a=red-green, b=yellow-blue). For example (Figure 15), with a noisy RGB color image 
an unsharp mask increases color speckle. Instead, convert the image mode to Lab, select the L 
(luminance or brightness) channel in the Channels palette, perform the unsharp mask, select each of 
the a and b channels (one at a time) and perform a Gaussian blur, and convert back to RGB. The 
sharpening (increased edge contrast) is present and the color noise is reduced (Figure 16).
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Figure 15. A noisy original image (Bird.tif), and the results of sharpening the original RGB image 
and performing the processing described above using Lab color space.

Figure 16. Enlarged details of the images shown in Figure 15. The color noise in the image 
sharpened in RGB space results from altering the proportions of red, green and blue. Processing 

in Lab space avoids this problem,
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6. Indexed color can be useful for creating pseudo-color images (Figure 17). Convert the original gray 
scale image to indexed color (Image -> Mode -> Indexed Color) and select Image -> Mode -> Color 
Table to choose one of the built-in color scales (Figure 18). You can also create custom tables, and 
save or reload them. To create a custom color look-up table (“CLUT”), click and drag on the 
displayed colors to select a range and then specify the colors for the start and end points, and repeat 
as appropriate to complete the table.

Figure 17. Converting a gray scale image (Butterfly.tif) to indexed color.

Figure 18. Selecting a color table for indexed color, and the Adobe Color-Picker dialog. If the native Mac 
or Windows color-picker has been selected in Preferences the dialog appearance is different.

X. Image size is a potentially confusing topic
A. One measure of image size is the number of pixels.
B. A second meaning is the dimension in real units (e.g., cm or inches) that controls how it will print.

1. Both the image size in pixels and the intended printing size are displayed in the Image -> Image Size 
dialog.

2. Copying and pasting an image into a word processing application will use the dimensions in real units, 
but some presentation programs (e.g. Powerpoint and many web page creating programs) and do not use 
this information. Many of these programs will discard pixels to reduce the image resolution to a low 
value appropriate for screen display, rather than saving the full original image (they may also reduce the 
number of bits per pixel and the color gamut). Such documents with reduced quality images should 
never be used for printed hard copy or for submitting papers for publication, and it is not possible to 
recover a good quality image from them.

C. A third possible meaning involves the magnification used to record the image, and is needed to perform 
measurements in real units such as millimeters or miles.

D. Printing generally works best with at least 200 pixels/inch. For most printers, 300 or more is better.
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1. Don’t be confused by printer “dots per inch” or dpi settings which are not directly related to the pixels.
E. Changing the image size (Image -> Image Size) can be used either to adjust the printing dimensions (and the 

pixels/inch) OR to alter the number of pixels in the image (Figure 19). In the latter case interpolation is 
used to insert or remove pixels. Bicubic interpolation produces the smoothest appearance, but Nearest 
Neighbor preserves pixel values.

1. If “Resample Image” is unchecked, the document size can be changed but not the pixel dimensions.
2. Checking “Constrain Proportions” when resampling will adjust the width and height together.

Figure 19. The Image Size dialog (used in this example to resample the image).
3. The File -> Print dialog allows adjusting the scale for printing, or automatically adjusting the image size 

to fit the paper, without altering the image in memory. No interpolation is performed.
F. Changing the canvas size (Image -> Canvas Size) adds space around the image (for labels, pasting another 

image, etc.).
1. The “Anchor” selection allows positioning the original image in the center, corner, or at any edge of the 

enlarged canvas area (Figure 20).

Figure 20. The Canvas Size dialog.

XI. Preferences that matter:
A. Select Edit -> Preferences in Windows, Photoshop -> Preferences on the Mac.
B. The number of history states and whether to save the history.
C. The interpolation method to be used (bicubic is usually the preferred choice for image appearance, but 

nearest neighbor will preserve pixel values if you are doing fluorescence, densitometry, etc.).
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D. The style used for the various tool cursors (some styles may be easier to see on the image).
E. The location for Photoshop’s scratch files (should be big and fast).
F. The location of a folder with any additional plug-ins.
G. The image cache should be set to 1 (higher values allow Photoshop to approximate the histogram and create 

displays for large images rapidly by sub-sampling the image).
H. Whether images are opened in separate windows, or as tabs (not so convenient for varying sizes).

XII. Other menu selections you will use frequently:
A. File -> New, Open, Browse, Open Recent, Close, Save, Save As, Revert, File Info, Print with Preview.

1. File -> New creates a new window, which will be preset by default to the size and mode of whatever 
image or fragment you have most recently copied to the clipboard.

2. File -> Browse opens a separate program (“Bridge”) that displays images visually for selection.
3. File -> Save As allows choosing the file format (some formats cannot preserve the full image 

information and will only save a flattened copy of the image).
4. File -> Revert reloads the stored version of the current image from the disk file.
5. File -> File Info shows the History Log, if it has been saved.
6. File -> Print allows adjustment of image size (pixels per inch) to fit the page.

B. Edit -> Copy, Paste, Fill, Stroke, Transform.
1. Edit -> Copy requires a selection. Use Select -> Select All (Control-A) for the entire image.

a. Edit -> Copy (Control-C) copies from the current selected layer.
b. Edit -> Copy Merged (Shift-Control-C) copies the image appearance including any text layers, etc. 

(i.e. a flattened copy).
2. Edit -> Paste (Control-V creates a new layer for the copied image. If the size is not the same as the 

current image the pasted image is centered.
3. Edit -> Fill and Edit -> Stroke draw on the current image using the foreground color and the selection 

bounds.
4. Edit -> Transform (Figure 21) rotates, shifts or scales a layer or selection. Click the check icon for OK. 

Figure 21. The transform options bar.
C. Image -> Adjustments -> Levels, Curves, Hue/Saturation, Channel Mixer, Invert, Threshold.

1. Adjustment of brightness and contrast should always be done last, after any other processing, because 
processing operations can alter the image brightness and contrast, and the shape of the histogram.

Figure 22. The Levels dialog allows setting black and white points, and a medium gray point, directly on 
the histogram. Typically the b/w points should be set at the ends of the histogram, so that only a few 

pixels are clipped to the extreme values (depress the Alt key while adjusting the ends to see the pixels 
affected). Adjusting the gray point sets the gamma value.
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2. Image -> Adjustments -> Levels (Figure 22), Image -> Adjustments -> Curves (Figure 23) and Image -> 
Adjustments -> Hue/Saturation (Figure 25) provide different ways to adjust color and brightness 
(Figures 24 and 26).

a. If the histogram in the Image -> Adjustments -> Curves dialog appears reversed left to right 
compared to the histogram shown in the Histogram palette and in the Image -> Adjustments -> 
Levels dialog, click on the Curve Display Options button and select “Show Amount of Light.”

Figure 23. The Curves dialog produces equivalent results to the Levels dialog. In addition to dragging the 
points on the curve relating original to resulting brightness, the eyedropper tools can be used to locate 

points on the image that should be set to black, white and medium gray.

Figure 24. Adjusting contrast and brightness improves the visibility of detail in a low contrast 
image (Butterfly.tif).
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Figure 25. The Hue/Saturation dialog. The Hue slider rotates the colors, while Saturation 
increases or decreases the amount of color.

Figure 26. Altering hue and saturation (Bird.tif).

3. Image -> Adjustments -> Channel Mixer creates monochrome (gray scale) images from color images 
(Figures 27 and 28). Vary the proportions of the color channels to increase contrast for important 
details.

Figure 27. The Channel Mixer dialog.
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Figure 28. The Channel Mixer result (Bird.tif) from Figure 27.

4. Image -> Adjustments -> Invert (Control-I) reverses black and white, like a photographic negative 
(Figure 29).

Figure 29. Inverting image contrast (Butterfly.tif).

5. Image -> Adjustments -> Threshold sets all pixels darker than an adjustable value to black, the rest to 
white (Figures 30 and 31).

Figure 30. The Threshold dialog, showing the level marker and value with the histogram.

Page 15



Figure 31. Threshold allows selecting a gray scale value to convert all darker pixels to 
black and all lighter ones to white (Butterfly.tif).

D. Image -> Duplicate, Rotate Canvas, Crop.
1. Rotate flips an image in 90 degree steps, or mirror reverses it.
2. Crop discards the portion of an image outside the current selection rectangle.

a. The crop tool also has other uses such as perspective correction.
E. Filter -> Blur, Noise, Sharpen, Stylize, Other -> Custom, Plug-ins.

1. Some processing functions such as Filter -> Blur -> Gaussian; Filter -> Noise -> Median (Figures 32 and 
33); Filter -> Sharpen -> Unsharp Mask (or Smart Sharpen); and Filter -> Stylize -> Emboss 
(Figures 34 and 35) implement processing algorithms that are useful for scientific images. Most 
dialogs have a Preview box that can be checked and unchecked to see the results of the filter.

a. The best way to learn about the operation of these processing functions is to apply them to various 
images and to check and uncheck the Preview box to see the effects they produce.

2. Filter -> Other -> Custom (Figures 36 and 37) is a good introduction to convolution. An array of weights 
(called a Kernel) used to combine image values can be saved to disk and reloaded.

a. The weight values are multiplied by each pixel and those in its neighborhood. The products are 
summed, divided by the “scale” value, and then added to the “offset” to produce a new value for 
the pixel.

b. Convolution kernels can produce smoothing, averaging, lo- or high-pass filtering, directional 
derivatives, and other results.

3. Third-party plug-ins with more advanced functionality appear below the line in the Filter menu.

Figure 32. The Median filter dialog allows adjustment of the neighborhood size used to reject noise (Cat.tif).
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Figure 33. The median filter is preferred to a Gaussian blur for noise removal because it 
preserves the location and contrast of edges and lines (Cat.tif).

Figure 34. The Emboss dialog controls the direction of a first derivative applied to the pixel 
values.

Figure 35. A derivative parallel to the ruled lines eliminates them, and makes the sequence of strokes in 
the writing more evident (Writing.tif).
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Figure 36. The Filter -> Other -> Custom dialog showing values for a Laplacian convolution.

Figure 37. The result of a Laplacian convolution (Butterfly.tif).

F. Window -> Arrange, Workspace.
1. Window -> Arrange provides a handy way to clean up the desktop when many images are open. It is 

also possible to select individual images by name from the Window menu.
2. Window -> Workspace is used to select an arrangement of palettes that has been previously saved. You 

may have several different workspaces convenient for different types of work or images.

XIII. Shortcuts
A. In most dialogs, hold down the Alt key to change the Cancel button to Reset, which restores the image and 

all dialog settings to what they were when the function was called.
B. Many dialogs have a "Preview" check box that allows seeing the effect of the settings on the image by 

turning the preview on and off.
C. There are many operations that have multiple equivalent ways to select.

1. For example, image zooming on screen can be accomplished in several ways:
a. Using the magnifying glass tool (depress Alt with the tool for zooming out).
b. Control-Space changes any tool temporarily to the magnifying glass.
c. Control-+ and Control-– zoom in and out.
d. The scroll wheel on the mouse can be used for zooming if this option is selected in Preferences.
e. Double-click on the magnifying glass tool or Alt-Control-zero to return to 100%.
f. The magnifying glass options bar has a check box to automatically change window size with zoom. 

This can also be set in the Preferences
D. Keyboard shortcuts can be customized, in addition to the many built-in ones.
E. Right-click on the image for a floating menu whose contents depend on the tool in use (sometimes these are 

helpful as a shortcut to select tool or layer options, sometimes not).
F. Depress the Space bar to temporarily change the cursor to the hand tool to scroll the image.
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G. The Alt-[ and Alt-] combinations select layers above or below the current one, but only those layers that 
have been set to visible and not the background layer.

H. Fine-tuning the placement of a selection outline can be done with the arrow keys to move one pixel in any
direction. Hold down the control key to also move the contents of the selection.

XIV. Advanced topics may be considered as time and interest warrant:

A.  Adjustment Layers can be used, as compared to simple image adjustments. 
The image processing adjustments described above (Image -> Adjustments -> Levels, Curves, Hue/

Saturation, Channel Mixer, Invert, Threshold) can also be made using an adjustment layer (Layers -> New 
Adjustment Layer) rather than being applied directly to the pixel values. An adjustment layer appears in the 
Layers palette (Figure 38) and has the advantage that  the original underlying image is not modified and the 
settings of the adjustment can be modified by clicking on the adjustment layer to select it, or turned off by 
clicking on the eye symbol for the layer. It is also possible to restrict the adjustment to a region within the 
image (with the selection in effect, create the adjustment layer and click on “Use Previous Layer to Create 
Clipping Mask”).

Figure 38. An adjustment layer applied to a region within an image.

B. Actions record and play back automated sequences of operations.
Recording an action (select New Action in the drop-down menu in the Actions palette) by working 

through a sequence of operations preserves every step and every parameter for each function (Figure 39). 
The steps can be edited, deleted, rearranged, and new ones inserted.

To temporarily bypass a step, uncheck it in the left hand column. To pause at the dialog box for a step 
(so that manual adjustments can be made), insert a check in the second column. Actions can be assigned to 
function keys, and sets of actions can be saved to disk. Actions recorded under one version of Photoshop are 
not always fully compatible with other versions. Actions can use other actions as subroutines, allowing 
complex operations to be built up incrementally.

To add a step to an existing Action, highlight the step before the location for the new entry and select 
Start Recording in the drop-down menu (or click on the round “Begin Recording” icon at the bottom of the 
Actions palette), and perform the step or steps. When finished, select Step Recording in the drop-down 
menu or click on the square “Stop Recording” icon at the bottom of the actions palette.

Entries in an action can be moved by clicking on the entry, and dragging (with the mouse button held 
down) to the new location. Entries can also be dragged from one action to another, or dragged to the trash 
can at the bottom of the palette. The latter act is equivalent to highlighting a step in an action and selecting 
Delete from the drop-down menu. 
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Figure 39. The actions palette records every step of an automated sequence. 
Batch processing (Figure 40) performs automatic operations on each image in a folder, using the steps 
specified in an action, and can optionally save the resulting images with new names to a different folder. The 
“Override Action Open” and “Override Action Save As” boxes allow the action to be applied to every image 
in the folder, not just the one originally named in the action.

Figure 40. The File -> Automate -> Batch dialog.
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C. Colorizing (or color-tinting) images may be useful for posters, etc.
Many people are interesting in learning this technique. Although it is not a true “scientific” use of the 

software, it does produce results that can be useful for displays and presentations, and in some cases it can 
rise to the level of art. Several methods can be used, but a particularly simple and straightforward one is 
shown here. Begin with a grey-scale image such as Pollen.tif (Figure 41) and convert it to RGB mode.

Figure 41. The Pollen.tif image after colorizing some regions.

Use Layer-> New -> Layer to create a new, empty layer on top of the image. In the Layers palette, use 
the pull-down menu to set the blending mode to Color (Figure 42).

Figure 42. Colorizing an image using a single Color layer.

Select the paint brush tool, adjust the size and hardness (the blurring at the edge of the brush) as required 
by the size of the details in the image (Figure 43), click on the foreground color in the Tools palette and 
select a color, and paint over a feature in the image. Continue to select colors and paint features as desired. 
Finally, adjust the layer Opacity in the Layers palette to control the saturation of the colors and the final 
appearance of the image. The image can be saved as a *.tif or *.psd file with the separate color layer, or 
flattened (Layer -> Flatten Image) and saved in any format.

Figure 43. Adjusting the size and hardness of the paintbrush
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Another "presentation" effect that is often desired is the addition of a watermark to the image. This may 
be a title or magnification mark, but in many cases is a copyright notice. Use the Type tool to enter the 
desired text, which will appear in a separate text layer on top of the image. Select an appropriate font 
(usually sans-serif fonts look best) and size; the color should be black. (Note:The copyright symbol © is 
produced on the Macintosh as Option-g. On the PC, hold down the Alt key while typing 0169 on the 
numeric keypad, then release the Alt key. Another useful trick is to copy any special symbols you need, e.g. 
from a web page, or from the Windows Character Map (Start->Acessories -> System Tools -> Character 
Map, and keep them in a text file so they can be copied and pasted later into your Photoshop text entry.) 

The text layer must be converted to a pixel layer (Layer -> Rasterize -> Type). Depending on the size of 
the type, you may optionally apply a small Gaussian blur (e.g., radius = 0.5 pixel). Next select Filter -> 
Stylize -> Emboss to produce a shading effect on the letters. Adjust the angle and height (width) of the 
embossing effect as desired, and click OK. Finally, change the layer mode to Overlay (Figure 44). This layer 
can be positioned using the Move tool or by holding down the Control key and using the arrow keys. You 
can also draw lines or shapes in a separate layer, and then rasterize and emboss them. As many separate 
layers with text, symbols, lines and shapes can be used as desired, which will combine to produce the 
watermark.

  
Figure 44. Setting the Layers mode to Overlay for a watermark.

D. Printing images: the tradeoffs.
Dye-sublimation printers produce near-photographic quality output but are expensive, slow and use 

consumables (paper and dye sheets) that cost several dollars per print. They have been almost entirely 
superseded by ink jet and laser printers. The latter are moderately expensive, but are fast and produce decent 
results, even on plain paper, for pennies per copy. Ink jet printers are quite inexpensive but slow, and require 
special coated papers and inks to produce quality output (about a dollar per print). But because the visual 
quality is good, they are usually the first choice. Sending images out via internet to a service bureau (even 
Wal-Mart) is also a practical option in some cases, but color fidelity may be compromised. Many service 
bureaus offer printing on wide, roll-stock paper that is well suited to presentation posters.

Laser printer performance is specified as dots per inch, or dpi, but this refers to the individual black or 
colored toner dots and is only indirectly related to the pixel resolution since clusters of dots are used to 
produce proportional amounts of gray or color. A “1200 dpi” printer with CMYK toner can produce half-
toned images of reasonable quality, adequate for reports.

Ink jet printer performance is typically specified as the drop size of each individual dot. Picoliter drops 
from 6 or more different colored inks produce good visual results, provided high quality specialized papers 
are used with coatings that control the extent to which the ink penetrates the fibers. Dye-based inks produce 
somewhat better results than pigment-based inks in terms of color range and fidelity, but are not archival 
(sensitive to light, humidity, etc.).

Except for commercial offset presses, which handle CMYK image modes directly, all printer driver 
software expects an RGB mode image. The gamut (color range) of images printed onto paper is noticeably 
less than that of images shown on a computer monitor, both in terms of maximum saturation and the range 
of hues that are recorded. The printer driver software converts the RGB values to the appropriate amounts of 
ink or toner. It is almost always best to set the color management options in the printer dialog to “Let Printer 
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Determine Colors” and “Relative Colorimetric” rendering intent, which will preserve differences in color at 
the expense of attempting to reproduce colors exactly.

Setting the output sliders in the levels adjustment dialog to slightly greater than black or less than white 
can be useful if you want to add true black or white annotations to the image. (It is also useful for printing if 
your printer does not handle pure white or black well, and the transition from grays to the extreme values is 
not smooth in appearance - you should test it by printing an image of a continuous gradient.) Other steps to 
calibrate your printer output so that the results match the on-screen appearance may also be needed. Printing 
is a complex topic that is covered in detail in many books, including those mentioned above. Devices to 
calibrate your cameras, scanners, display monitors, and printers exist and are very worthwhile and not too 
costly, if you need them.

E. RAW images can be acquired from some cameras: why and how to use them.
Many digital cameras can save the unprocessed, linear values from the camera chip. These cover a high 

dynamic range and can be processed by the Camera Raw software to make adjustments (Figure 45). This 
includes changing the exposure, color temperature, sharpness, etc., as well as correcting lens defects. Once a 
set of adjustments has been established, it can be saved for future use. Raw images should generally be 
opened as 16 bit per channel RGB images to preserve the full available information. The original raw image 
file is not altered and the copy that is opened should be saved as a separate file.

Anyone planning to do serious work using raw files should get the book “Real World Camera Raw with 
Adobe Photoshop CS3,” B. Fraser and J. Schewe, Peachpit Press, 2007, as it contains a wealth of practical 
information. (Bruce Fraser died in 2006, but his books have been updated by co-authors and continue to be a 
valuable source for Photoshop users). 

Figure 45. A few of the adjustment panels in the RAW image dialog.
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F. Using Bridge to organize image files
Bridge is a companion program to Photoshop, which is automatically run when you click on File -> 

Browse in Photoshop. Bridge is capable of managing many different kinds of files. In addition to a wide 
variety of image formats, this includes pdf files, sound files, web documents, and all of the formats used by 
other Adobe applications such as Flash and Illustrator. Only its use for images is dealt with here. Choosing 
one or more images in Bridge and selecting File -> Open will automatically run Photoshop (if it is not 
already running) and open the image(s). For "Raw" files stored directly from a camera, it is also possible to 
use Bridge to open the image directly into the Camera Raw software, which provides all of the same 
capabilities as opening the raw file directly into Photoshop.

A large window is displayed (usually taking over your entire monitor) which shows thumbnail 
representations of images. Your first step will usually be to arrange all of the various panels to suit your 
needs, and then select Window -> Workspace -> Save Workspace to preserve the layout for future use 
(multiple workspaces may be set up to suit different needs). The window is divided by horizontal and 
vertical sliders that can be dragged to adjust the size of the various panels, and the tabs can be dragged to 
move the individual palette windows to a panel.

The most used panels are typically Content (which shows the thumbnails), Preview (which shows a 
larger image of one or more selected files), Folders (which shows the hierarchical path to the selected 
folder), Favorites (you can right-click on a selected folder to add it to the favorites panel, or drag folders of 
images there to make them quickly selectable), Filter (which offers a variety of tools for selecting groups of 
images), and Keywords (used to assign descriptive words to images that can be used for selection).

In its simplest mode of use, Bridge can be used to open a folder of images, showing thumbnails of all of 
the images. Clicking on an image thumbnail will show a larger preview in Preview panel (hold down the 
Control key to select multiple images, or the Shift key to select a range of images). These can then be 
directly opened into Photoshop.

However, Bridge can do much more to organize image files. In the Filter panel, the ordering of the 
thumbnails can be by filename (the default), file type, creation date, and so on. Also, by assigning 
"Ratings" (one to five stars) or "Labels" (color tags representing named categories, which can be assigned in 
the Preferences by clicking on Labels) it is possible to quickly locate files. The Sort By list in the Filter 
panel also allows using these categories for ordering the thumbnails. The folder icon at the top left of the 
Filter palette is a toggle that will include images in any subfolders in the Content display. The Filter Palette 
can also be used to select images by various defined criteria such as the file creation date, file type, and so 
on.

Probably the most important feature of the Filter panel is the ability to select images by Keywords. A list 
of keywords is created by selecting New Keyword from the drop-down menu in the Keywords palette (or 
clicking on the "+" button at the bottom of the palette), and providing a name for the group of words to be 
created. Then select New Sub Keyword from the drop-down menu (or the corresponding button at the 
bottom of the palette) and enter one of the specific terms that will be useful for classifying and selecting 
images. For example, these might include categories such as different types of microscopes (SEM, TEM, 
Fluorescence, etc.), or different subjects (names of children, or kinds of specimens, etc.), or different 
operators. There are no practical limits to the number or specificity of keywords.

To assign keywords to one or more images, and click on the desired keyword in the Keywords palette. 
There is no practical limit to the number of keywords that can be assigned to each image. Once the 
keywords have been assigned, the Filter palette makes it easy to select images by one or multiple keywords. 
The list of all keywords that are in use is shown in the palette. Clicking on a keyword will show thumbnails 
of only those images in the Content panel that have the keyword. Clicking on additional keywords will add 
to the display to those that have any of the checked words (clicking on a checked word will uncheck it and 
remove that class). Note that this use of keywords is a logical OR. There is no provision for a logical AND 
to select images that have multiple keywords assigned, but the selection of different categories in the filter 
menu (such as keyword, file type, rating, label, date created) does function as a logical AND.
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G. Saving a record of image processing steps

Saving a permanent record of any processing applied to an image is an important procedure for all 
scientific and forensic work. One particularly convenient way to accomplish this is Photoshop’s History 
Log. Selected under Edit -> Preferences (or Photoshop -> Preferences on the Macintosh), the History Log 
can be saved either to a text file or to the metadata written to the image file itself (usually the best choice). 
The full details of every processing operation should be selected (Figure 46).

The History Log for an image can be viewed by selecting File -> File Info and selecting History (Figure 
47). The history can also be viewed in Bridge. 

Figure 46. Setting the Preferences to store the History Log.

Figure 47. An example of a History log saved in the file.
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H. A practical approach to workflow
The following sequence of steps is appropriate in the majority of situations in which images are prepared 

for visual examination (additional steps will be needed for automatic measurements). It is strongly 
emphasized that no "recipe" of steps should ever be followed without understanding what each operation 
does and why it is used.

1. Acquire and maintain the images with the maximum possible dynamic range and (for color images) with 
the largest color gamut. If supported by your camera or scanner, the image mode should be 16 bits per 
channel and the working color space should be Adobe RGB (Edit -> Color Settings) which has much 
greater latitude than the default sRGB.

2. Save the original image in a format such as *.tif or *.psd that preserves the full dynamic range and does 
not introduce any lossy compression. Save separate copies after processing, and keep a permanent 
record of all processing operations.

3. For color images, perform any color corrections that are needed first. Most subsequent processing 
operations are best performed on just the intensity and not the color. For this purpose, the image mode 
can be changed to Lab (Image -> Mode -> Lab Color) and just the Lightness channel selected (in the 
Channels palette). After processing, convert the image back to RGB for printing.

4. If the image contains random (speckle) noise, reduce it by applying a median filter (Filter -> Noise -> 
Median). Adjust the Radius value to reduce or remove the noise, keeping it small enough that important 
details are not erased. The median filter is almost always a better way to remove noise than a Gaussian 
blur, which simply blends the noise into the image details, reduces edge contrast, and can shift edges.

5. Only after the steps above should contrast adjustments be made. Setting the black and white limit points 
on the histogram (Image -> Adjust -> Levels) performs a linear contrast expansion, and should be done 
with little or no clipping of values at either end. If necessary, nonlinear adjustments such as gamma may 
be made by sliding the middle gray marker on the histogram, or more customized adjustments made by 
adjusting the shape of the transfer function using Image -> Adjust -> Curves.

6. Enhancement of local detail can be performed using an unsharp mask (Filter -> Sharpen -> Unsharp 
Mask. This increases the contrast of steps and lines. The Radius slider controls the size of a Gaussian 
blur applied to remove detail from a copy of the image which is then subtracted from the original. The 
details, which are the difference produced by this subtraction, are then added back to the original image 
as controlled by the Amount slider. In most cases the Threshold slider can be left at zero.

7. Annotations (text, lines and arrows, etc.) should be added to the image in a separate layer. Flattened 
copies may be saved separately for printing, embedding in reports, articles or web pages, etc. These 
copies may be reduced to 8 bits per channel and saved in whatever format is required or appropriate. 
Images that have been pasted into other documents (e.g., Word or Powerpoint files) are significantly 
reduced in quality and should never be extracted and used for any other purpose.

8. Printing of images for reports, posters, etc., should make use of high quality paper and inks (for ink jet 
printers), and be performed with a pixel density of 200-300 pixels per inch whenever possible. If image 
size adjustments require interpolation, selecting Bicubic usually produces the most visually pleasing 
results.
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XV. Ethics and Images

Many of my books and other publications deal with the methods by which images can be processed. The 
important question of what constitutes proper and appropriate processing and what constitutes unethical or even 
fraudulent manipulation must be considered. The short answer is that anything that alters an image so as to 
create a false impression on the part of the viewer is wrong. The problem with that answer is that it does not 
take into account the fact that different viewers will tend to see different things in the image anyway, and that 
what constitutes a false impression for one person, may not for another.

The first, vitally important rule is always to store a permanent copy of the original image along with relevant 
data on its acquisition. The second rule is to carefully document whatever steps are taken to process the image, 
and generally to report those steps when the processed image is published. Most scientific publications, and the 
editors who review submitted papers, have become more aware in recent years of the ease with which image 
processing can be performed, and the dangers of inadequate documentation. (For example, see M. Rossner, K. 
M. Yamada (2004) “What’s in a Picture” J. Cell Biology 166:11-15 for that journal’s policy on image ethics, 
and examples of improper manipulation.)

Some procedures, such as rearranging features or combining them within a single image, or differently 
adjusting the contrast of several images to make them appear more alike, are clearly misleading and generally 
wrong. Some, such as using copy-and-paste to duplicate a portion of an image, or selectively erasing portions of 
an image, are out-and-out fraudulent. Editors and reviewers try to catch these problems, but ultimately it is the 
responsibility of the author to make sure that the data presented (whether images or anything else) are correct. 
Even selective cropping of an image (or choosing which field of view to record) can create a false impression.

An important but often overlooked concern is to avoid using programs that alter the image without the user 
being aware of it. For example, carefully correcting the colors in an image using Photoshop and then placing it 
in Powerpoint for presentation will cause changes even on the same computer screen (as well discarding pixels 
and reducing resolution if copy-and-paste is used for the transfer). In addition the image may appear different 
on another computer monitor, or when using a projector. Printing an image will also alter colors unless careful 
calibration is performed beforehand. Devices to calibrate cameras, scanners, monitors, and printers exist, but are 
not widely enough used, and even then do not assure accurate reproduction in a publication. Placing images into 
a figure using Illustrator makes it all too easy to adjust the size or position of an image that will result in 
interpolation and alteration of pixel values (rotation is especially bad in this regard). Placing images into a web 
page for viewing can cause all of these problems at once. And using any lossy compression method such as jpeg 
will discard potentially important information that cannot be recovered.

Some processing operations are used to correct for the conditions under which an image is acquired, or the 
equipment limitations used to record it. For example, if it is intended to compare the colors in two images of the 
same scene or object, but they have been acquired under different lighting conditions (for example outdoors or 
indoors, or fluorescent and incandescent lamps), it is necessary to correct the colors in the images. With 
conventional film photography, this was typically done in the darkroom by using different colored filters to 
compensate for the different lighting conditions, and was usually not reported.

With digital images, the corrections are performed in a computer. If this can be done by having recorded a 
known standard palette of colors in the scene, or if certain assumptions can be made about the presence of 
neutral (grey) regions in the image, the procedures are straightforward and acceptable. If other assumptions and 
methods are used, they may be acceptable but they must be fully reported.
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Other processing operations that are usually considered non-controversial (but can still be abused) 
correspond more-or-less directly to procedures that were applied in the darkroom with conventional film 
photography. For example, adjustments can be made to brightness and contrast in order to make visible the 
details in the image that are considered important to show the objects or scene represented. Of course, it is the 
judgment of the author as to what is important, and since film has a much broader dynamic range than the print, 
not everything on the film can generally be shown in the print. Details that might be important may be lost, 
especially if values become completely black or white. 

The same thing is true for digital images. Adjusting the sliders for gain and contrast (or more commonly the 
sliders that define the dark and light limits for the displayed and printed pixels) is a function provided in most 
programs, such as the ubiquitous Photoshop. But these programs have additional sliders that introduce 
nonlinearities in the brightness and contrast. When these are used, contrast for some portions of the brightness 
range can be increased but only by reducing contrast elsewhere. Some pixel values that were originally different 
will become identical, and this is unrecoverable (another reason why the original camera image must be 
preserved). If the pixel values recorded by the camera or scanner have direct meaning, such as density values, 
neither linear or nonlinear adjustments can be permitted.

There is an inherent danger that the various sliders may be moved and adjustments made by someone with 
independent knowledge (or strong desire) about what the image shows (or should show) and the manipulations 
will be done to achieve that as a goal, rather than from a proper consideration of what the various adjustments 
actually do. It takes an investment of time and effort to learn about image processing algorithms, and their 
implementation in specific programs, so as to understand when and how to use them. Ignoring that requirement 
is risky. Most scientists accept the fact that they must know how their microscope and other instruments work; 
knowing how the camera and software function is fully as important but sometimes overlooked.

Software also makes it easy to perform differing adjustments on the brightness and contrast of several 
images, or even of different regions within an image. If this is done, there must be a good reason (e.g., one part 
of the scene is in a shadow and the other in direct sunlight) and it must be documented. It can be very difficult to 
record images with perfectly uniform illumination, and even then many cameras suffer from vignetting 
(darkening of the corners) due to the optics. Software can correct this, and indeed is necessary to allow 
thresholding and measurement of features in different regions of the image. But the fact that the step was 
performed and the method that was used must be reported.

When more aggressive processing is used, such as high pass filters to delineate edges, or deconvolution to 
correct for focus blur, or Fourier filtering to remove electronic interference, it should also be documented. The 
general guideline to be considered is that it is never acceptable to add anything to an image, but it may be 
acceptable to suppress or remove some information if it makes the remaining details more accessible, either 
visually for presentation and communication, or to facilitate measurement. Of course, the procedures used must 
be reported. For example, the initial Hubble telescope pictures were badly out of focus, but it was possible and 
acceptable to remove the blur by deconvolution, and this was fully reported. As another example, the location of 
the edges of features is vital to allow their accurate measurement, and methods that increase their contrast 
(without causing them to shift) are acceptable and even necessary.

Any of the procedures shown here and in my books (and many others) may be appropriate in a given 
instance. But they can also be mis-used, and should in any case never be used without understanding and full 
documentation. The heart of the scientific method is replicability. If adequate information is provided on the 
processing steps applied, and the original image data are preserved, then the validity of the results can be 
independently verified.
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